What should I do if checksum mismatch errors occur?

What should I do if checksum mismatch errors occur?

Symptoms

You received a notification regarding checksum mismatch errors.

Notes:

  • To find out which files are affected, check the logs in Log Center > Logs.

Diagnosis

The Btrfs file system cannot repair the damaged data.

Resolution

The Btrfs file system uses checksums to ensure data integrity. The file system can automatically detect corrupted data (i.e., silent data corruption) and rely on its self-healing technology to recover corrupted data.

To resolve a checksum mismatch error:

If the Btrfs file system fails to restore the corrupted data, the data will be inaccessible. You can only recover the data if you have backed them up to an offsite location before data corruption occurs.1

To prevent a checksum mismatch error:

A Checksum mismatch error is caused by many factors, such as defective drives, faulty memory modules, or non-Synology memory module installation.

  • Run a memory test on your Synology NAS to identify any faulty memory modules.
  • Avoid using non-Synology memory modules. If non-Synology modules are already installed in your Synology NAS, please remove them to prevent further data loss. Other unexpected system errors may occur when a memory module that is not compatible with the product model is used to expand the memory on your Synology server.
  • Perform data scrubbing regularly to ensure data integrity and minimize data loss.
  • Back up your Synology NAS periodically to safeguard your data.

Notes:

  1. If data are already corrupted, you might not be able to restore the data via an onsite backup solution (e.g., Snapshot Replication or Synology Drive) because the backed up or synchronized data may also be corrupted.
Symptoms
Diagnosis
Resolution
To resolve a checksum mismatch error:
To prevent a checksum mismatch error: